Blognhung.no1.vn
Công ty TNHH TM&DV Minh Đức Chuyên cung cấp Máy tính PC,Notebooks,Linh kiện máy tính như RAM,CPU,Mainboard,HDD,Card màn hình,Card mạng,Case+Nguồn..!Các loại Notebook như Dell,Sony VaiO,Asus,Acer,HP,Lenovo,Toshiba...Có các loại,mới+Cũ.Ngoài ra còn cung cấp Máy in,Scaner,Photo,Fax..dây mạng và thiết bị mạng.Vui lòng đóng góp những sản phẩm mới của bạn lên Website www.minhduccomputing.no1.vn và lựa chọn cho mình 1 sản phẩm phù hợp với túi tiền của bạn.Chúc các bạn có 1 ngày làm việc vui vẻ,hiệu quả.Mọi thong tin chi tiết xin phản hồi về Admin Dungviet_it-+819066559891 Japan-Braverybkap@gmail.com Số 1 Ngõ 283 Trần Khát chân HBT HN

Blognhung.no1.vn

Forum cá nhân Phan Nhung
 
Indexwww.pnh.com.vnCalendarGalleryTrợ giúpTìm kiếmThành viênNhómĐăng kýĐăng Nhập

Share | 
 

 Cấu hình SSH cho Router trên thiết bị của Cisco

Xem chủ đề cũ hơn Xem chủ đề mới hơn Go down 
Tác giảThông điệp
DungViet_IT
Admin
Admin


Tổng số bài gửi : 101
Points : 294
Join date : 27/12/2010
Age : 27
Đến từ : Xư nghệ đất lửa

Bài gửiTiêu đề: Cấu hình SSH cho Router trên thiết bị của Cisco   Sun Jan 02, 2011 11:58 pm

Cấu Hình SSH Cho Router

Mô hình bài Lab như sau



Trong bài lab trước ta đã biết cấu hình router từ xa thông qua giao thức telnet tuy nhiên telnet là một giao thức không có tính bảo mật. Thông tin được gửi đi dưới dạng cleartext. Như vậy để nâng cao tính bảo mật ta sẽ dùng giao thức SSH thay thế cho telnet.
Các bước cần phải làm cho bài lab như sau
- Cấu hình địa chỉ IP vào các interface của router . Cấu hình static route trên Router 1 và Router 2
- Ping kiểm tra từng segment trong mô hình.
- Cấu hình SSH trên Router 1 và Router 2.
- Capture lại thông tin được trao đổi trên đường truyền.
1. Cấu hình địa chỉ IP và định tuyến cho mô hình bằng static route

a.Router 1
Router>enable
Router#configure terminal
Router(config)#interface serial 2/0
Router(config-if)#ip address 12.0.0.1 255.255.255.252
Router(config-if)#no shutdown
Router(config)#exit
Router(config)#interface serial fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config)#exit
Router(config)#interface loopback 0
Router(config)#ip address 10.0.0.1 255.255.255.0
Router(config)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.2

b. Router 2
Router>enable
Router#configure terminal
Router(config)#interface serial 2/0
Router(config-if)#ip address 12.0.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config)#exit
Router(config)#interface loopback 0
Router(config)#ip address 20.0.0.1 255.255.255.0
Router(config)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 12.0.0.1
Router(config)#ip route 10.0.0.0 255.255.255.0 12.0.0.1
2. Quá trình kiểm tra
- Từ Router 1 ping đến các IP của Router 2
- Ở PC ta dùng lệnh ipconfig và ping từ PC đến các interface của Router 1 và Router 2




3. Cấu hình SSH trên Router 1 và Router 2
Để cấu hình SSH ta cần phải cấu hình một số phần như sau:

 Cấu hình hostname
 Cấu hình domain name
 Tạo ra key từ hostname và domain name ở trên
 Tạo ra một username và password cho user đăng nhập vào Router.
 Cấu hình một số tính năng cho giao thức SSH trên router.
 Cấu hình cho giao thức SSH vào đường vty.
Trên Router 1 ta nhập vào những lệnh sau:
Router(config)#hostname R1
R1(config)#ip domain name abc.com
R1(config)#crypto key generate rsa general-keys modulus 1024
The name for the keys will be: R1.abc.com
% The key modulus size is 1024 bits
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
*June 24 19:25:30.035: %SSH-5-ENABLED: SSH 1.99 has been enabled
R1(config)# ip ssh time-out 60
R1(config)# ip ssh authentication-retries 2
R1(config)# ip ssh version 2
R1(config)# username cisco password cisco
R1(config)# line vty 0 4
R1(config-line)# login local
R1(config-line)# transport input ssh
R1(config-line)# exit
Tương tự ta cấu hình cho Router 2
Router(config)#hostname R2
R2(config)#ip domain name bcd.com
R2(config)#crypto key generate rsa general-keys modulus 1024
The name for the keys will be: R2.bcd.com
% The key modulus size is 1024 bits
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
*June 24 19:25:30.035: %SSH-5-ENABLED: SSH 1.99 has been enabled
R2(config)# ip ssh time-out 60
R2(config)# ip ssh authentication-retries 2
R2(config)# ip ssh version 2
R2(config)# username cisco123 password cisco123
R2(config)# line vty 0 4
R2(config-line)# login local
R2(config-line)# transport input ssh
R2(config-line)# exit

Ở PC ta tạo kết nối SSH đến Router 1 thông qua chương trình Putty




Lúc này ta phải chấp nhận key được tạo thông qua thuật toán RSA để tạo kết nối SSH.




Ta nhập vào username và password tương ứng mà ta đã tạo trên Router 1 để đăng nhập vào Router 1





Đứng ở giao diện dòng lệnh của Router 1, để tạo kết nối SSH đến Router 2 ta cần phải nhập câu lệnh sau:
R1#ssh -v 2 -l cisco123 -p 22 12.0.0.2





Nhằm mục đích kiểm tra tính năng bảo mật của giao thức SSH ta thực hiện quá trình capture các luồng traffic trao đổi trên router . Hình đầu tiên là ta capture traffic từ PC đến Router1.


Về Đầu Trang Go down
Xem lý lịch thành viên http://blognhung.forumvi.com
 
Cấu hình SSH cho Router trên thiết bị của Cisco
Xem chủ đề cũ hơn Xem chủ đề mới hơn Về Đầu Trang 
Trang 1 trong tổng số 1 trang
 Similar topics
-
» Động lực học tàu thủy
» Thiết bị trên boong
» Thiển cận...
» Tìm hiểu về hệ thống dẫn đường quán tính (INS)
» Danh mục thiết bị thông tin và liên lạc hàng hải

Permissions in this forum:Bạn không có quyền trả lời bài viết
Blognhung.no1.vn :: Giới Thiệu Chung :: Thế giới CNTT :: Tài Liệu Quản Trị Mạng-
Chuyển đến